summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..d26a677
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,23 @@
+AUTOMAKE_OPTIONS =
+EXTRA_DIST = README.en DIARY anthy-conf.in anthy-test-conf.in anthy.spec.in anthy.pc.in Doxyfile
+
+SRCDIR = src-diclib src-worddic src-splitter src-ordering src-main src-util
+
+SUBDIRS = $(SRCDIR) anthy depgraph mkworddic calctrans mkanthydic doc test alt-cannadic
+
+sysconf_DATA = anthy-conf
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = anthy.pc
+
+MOSTLYCLEANFILES = core
+
+update_params:
+ make -C calctrans update_params
+ make
+update_params0:
+ make -C calctrans update_params0
+ make
+update_params2:
+ make -C calctrans update_params2
+ make