summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 3 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 44cf7224d6..8dddebcf34 100644
--- a/setup.py
+++ b/setup.py
@@ -158,17 +158,9 @@ for extra_requirements_filename in os.listdir(extra_requirements_dir):
with open(os.path.join(extra_requirements_dir, extra_requirements_filename)) as extra_requirements_file:
extra_requirements[filename_match.group(1)] = extra_requirements_file.read().splitlines()
-try:
- with open('README.rst', 'r') as readme_file:
- longdesc = readme_file.read()
-except (IOError, OSError):
- longdesc = ('Ansible is a radically simple IT automation system. It handles'
- ' configuration-management, application deployment, cloud provisioning, ad-hoc'
- ' task-execution, and multinode orchestration - including trivializing things like'
- ' zero-downtime rolling updates with load balancers.\n'
- '\n'
- 'Read the documentation and more at https://ansible.com/'
- )
+# Retrieve the long description from the README
+with open('README.rst', 'r') as readme_file:
+ longdesc = readme_file.read()
setup(
# Use the distutils SDist so that symlinks are not expanded