summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJaroslav Kysela <perex@perex.cz>2010-09-07 15:35:14 +0200
committerJaroslav Kysela <perex@perex.cz>2010-09-15 08:09:31 +0200
commit1c79fad9692fb04cb8cbc7be8e2ec88595e62e46 (patch)
tree65e5d943e5d4f4d9c1e32b2d52bcca57116994b2 /src/Makefile.am
parentfcc9adb26058667656277ba92032ba7e0b00261c (diff)
downloadalsa-lib-1c79fad9692fb04cb8cbc7be8e2ec88595e62e46.tar.gz
ucm: Moved ucm to src/ucm subdirectory
- separate code to more files - use standard lists to represent structures - use alsa-lib configuration parser Signed-off-by: Jaroslav Kysela <perex@perex.cz>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7206dbdb..9a00dca3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,7 +14,7 @@ SYMFUNCS =
endif
lib_LTLIBRARIES = libasound.la
-libasound_la_SOURCES = conf.c confmisc.c input.c output.c async.c error.c dlmisc.c socket.c shmarea.c userfile.c names.c use-case.c
+libasound_la_SOURCES = conf.c confmisc.c input.c output.c async.c error.c dlmisc.c socket.c shmarea.c userfile.c names.c
SUBDIRS=control
libasound_la_LIBADD = control/libcontrol.la
@@ -38,6 +38,10 @@ if BUILD_SEQ
SUBDIRS += seq
libasound_la_LIBADD += seq/libseq.la
endif
+if BUILD_UCM
+SUBDIRS += ucm
+libasound_la_LIBADD += ucm/libucm.la
+endif
if BUILD_ALISP
SUBDIRS += alisp
libasound_la_LIBADD += alisp/libalisp.la