summaryrefslogtreecommitdiff
path: root/vapi/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-25 11:39:06 +0100
committerThomas Haller <thaller@redhat.com>2017-12-13 15:48:50 +0100
commit03637ad8b5d21fcc12a536a25caf46445aabde73 (patch)
tree3330fed2a9ad0f45c0c993a8aac6d3dee42ed101 /vapi/meson.build
parente96fabfc186510808cee1bf6aaaa28f460f1cea5 (diff)
downloadNetworkManager-03637ad8b5d21fcc12a536a25caf46445aabde73.tar.gz
build: add initial support for meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools. [thaller@redhat.com: rebased patch and adjusted for iwd support] https://mail.gnome.org/archives/networkmanager-list/2017-December/msg00022.html
Diffstat (limited to 'vapi/meson.build')
-rw-r--r--vapi/meson.build29
1 files changed, 29 insertions, 0 deletions
diff --git a/vapi/meson.build b/vapi/meson.build
new file mode 100644
index 0000000000..330d055191
--- /dev/null
+++ b/vapi/meson.build
@@ -0,0 +1,29 @@
+gnome.generate_vapi(
+ 'libnm',
+ sources: libnm_gir[0],
+ packages: 'gio-2.0',
+ install: true
+)
+
+if enable_libnm_glib
+ packages = [
+ 'dbus-glib-1',
+ 'gio-2.0'
+ ]
+
+ libnm_util_vapi = gnome.generate_vapi(
+ 'libnm-util',
+ sources: libnm_util_gir[0],
+ packages: packages,
+ install: true
+ )
+
+ packages += libnm_util_vapi
+
+ gnome.generate_vapi(
+ 'libnm-glib',
+ sources: libnm_glib_gir[0],
+ packages: packages,
+ install: true
+ )
+endif