summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig) <jan.steffens@gmail.com>2018-10-19 18:48:43 +0200
committerThomas Haller <thaller@redhat.com>2018-10-22 13:19:15 +0200
commite0b168d6a84141408c48126fb4f358df1222870c (patch)
tree088219abea3c5af002abb6f8e1a15d18732ecc30 /src/meson.build
parent581be6b8d2b34dac0050988d690d83da7c44f517 (diff)
downloadNetworkManager-e0b168d6a84141408c48126fb4f358df1222870c.tar.gz
meson: Fix platform tests
All platform tests were run twice with the `linux` platform, instead of `fake` and `linux`, as expected.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build13
1 files changed, 10 insertions, 3 deletions
diff --git a/src/meson.build b/src/meson.build
index f293f299b5..d58fb4d1f6 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -216,9 +216,6 @@ if enable_tests
test_cflags += ['-DREQUIRE_ROOT_TESTS=1']
endif
- platform = (host_machine.system().contains('linux') ? 'linux' : 'fake')
- test_cflags_platform = '-DSETUP=nm_' + platform + '_platform_setup'
-
libnetwork_manager_test = static_library(
nm_name + 'Test',
sources: sources,
@@ -233,6 +230,16 @@ if enable_tests
link_with: libnetwork_manager_test
)
+ test_nm_dep_fake = declare_dependency(
+ dependencies: test_nm_dep,
+ compile_args: ['-DSETUP=nm_fake_platform_setup']
+ )
+
+ test_nm_dep_linux = declare_dependency(
+ dependencies: test_nm_dep,
+ compile_args: ['-DSETUP=nm_linux_platform_setup']
+ )
+
subdir('dnsmasq/tests')
subdir('ndisc/tests')
subdir('platform/tests')