summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-03-11 11:37:40 +0100
committerThomas Haller <thaller@redhat.com>2019-03-13 09:47:37 +0100
commitb8398b9e7948caefbdc93d5bff208e8caf308a80 (patch)
tree533efa26027205223a62e0561f5b06926bd3f15b /src/meson.build
parent5ae2431b0f9e8dc2fbba5c9783852735a8db7c27 (diff)
downloadNetworkManager-b8398b9e7948caefbdc93d5bff208e8caf308a80.tar.gz
platform: add NMPRulesManager for syncing routing rulesth/routing-rule-pt1
Routing rules are unlike addresses or routes not tied to an interface. NetworkManager thinks in terms of connection profiles. That works well for addresses and routes, as one profile configures addresses and routes for one device. For example, when activating a profile on a device, the configuration does not interfere with the addresses/routes of other devices. That is not the case for routing rules, which are global, netns-wide entities. When one connection profile specifies rules, then this per-device configuration must be merged with the global configuration. And when a device disconnects later, the rules must be removed. Add a new NMPRulesManager API to track/untrack routing rules. Devices can register/add there the routing rules they require. And the sync method will apply the configuration. This is be implemented on top of NMPlatform's caching API.
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/meson.build b/src/meson.build
index 06a0dc57da..20a14f9f00 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -35,6 +35,7 @@ sources = files(
'platform/nm-platform-utils.c',
'platform/nmp-netns.c',
'platform/nmp-object.c',
+ 'platform/nmp-rules-manager.c',
'main-utils.c',
'NetworkManagerUtils.c',
'nm-core-utils.c',