summaryrefslogtreecommitdiff
path: root/src/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-12-28 18:11:16 +0100
committerThomas Haller <thaller@redhat.com>2019-01-02 17:07:13 +0100
commit2c537b9d2155118e5f6fe49386035659550ce64c (patch)
treeb989bd67082006ec9db9c331430f0f463a68bd27 /src/meson.build
parent616abe865dc7606b4325e1e44fff587c83ad1de7 (diff)
downloadNetworkManager-2c537b9d2155118e5f6fe49386035659550ce64c.tar.gz
systemd: move basic systemd library to shared/nm-utils
For better or worse, we already pull in large parts of systemd sources. I need a base64 decode implementation (because glib's g_base64_decode() cannot reject invalid encodings). Instead of coming up with my own or copy-paste if from somewhere, reuse systemd's unbase64mem(). But for that, make systemd's basic bits an independent static library first because I will need it in libnm-core. This doesn't really change anything except making "libnm-systemd-core.la" an indpendent static library that could be used from "libnm-core". We shall still be mindful about which internal code of systemd we use, and only access functionality that is exposed via "systemd/nm-sd-utils-shared.h".
Diffstat (limited to 'src/meson.build')
-rw-r--r--src/meson.build12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/meson.build b/src/meson.build
index ec1c4241c1..ff2276e3f8 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -176,7 +176,11 @@ libnetwork_manager = static_library(
sources: sources,
dependencies: nm_deps,
c_args: cflags,
- link_with: [libnetwork_manager_base, libsystemd_nm],
+ link_with: [
+ libnetwork_manager_base,
+ libnm_systemd_core,
+ libnm_systemd_shared,
+ ],
)
deps = [
@@ -193,7 +197,11 @@ executable(
name + '.c',
dependencies: deps,
c_args: cflags,
- link_with: [libnetwork_manager_base, libsystemd_nm],
+ link_with: [
+ libnetwork_manager_base,
+ libnm_systemd_core,
+ libnm_systemd_shared,
+ ],
link_args: ldflags_linker_script_binary,
link_depends: linker_script_binary,
install: true,