summaryrefslogtreecommitdiff
path: root/src/devices/tests/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-10-01 09:49:41 +0200
committerThomas Haller <thaller@redhat.com>2019-10-01 09:49:41 +0200
commit2cff04ea0933cddcf358af0288456f8b5bd60e1f (patch)
tree61efe41405e3fc0f82249316e94bde68b4a26b27 /src/devices/tests/meson.build
parent50f146f6e3c932e261af16706608a6e0508bbd5f (diff)
parent42a8533d5f35a2b3a6664f9228f9e1dce7708164 (diff)
downloadNetworkManager-2cff04ea0933cddcf358af0288456f8b5bd60e1f.tar.gz
build/meson: merge branch 'inigomartinez:meson-update'
https://gitlab.freedesktop.org/NetworkManager/NetworkManager/merge_requests/256
Diffstat (limited to 'src/devices/tests/meson.build')
-rw-r--r--src/devices/tests/meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/devices/tests/meson.build b/src/devices/tests/meson.build
index 4b4c5c7ee5..bb53d1ee47 100644
--- a/src/devices/tests/meson.build
+++ b/src/devices/tests/meson.build
@@ -7,8 +7,10 @@ foreach test_unit: test_units
exe = executable(
test_unit,
test_unit + '.c',
- dependencies: test_nm_dep,
+ dependencies: libnetwork_manager_test_dep,
+ c_args: test_c_flags,
)
+
test(
'devices/' + test_unit,
test_script,