summaryrefslogtreecommitdiff
path: root/src/devices/bluetooth/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-25 11:39:06 +0100
committerThomas Haller <thaller@redhat.com>2017-12-13 15:48:50 +0100
commit03637ad8b5d21fcc12a536a25caf46445aabde73 (patch)
tree3330fed2a9ad0f45c0c993a8aac6d3dee42ed101 /src/devices/bluetooth/meson.build
parente96fabfc186510808cee1bf6aaaa28f460f1cea5 (diff)
downloadNetworkManager-03637ad8b5d21fcc12a536a25caf46445aabde73.tar.gz
build: add initial support for meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools. [thaller@redhat.com: rebased patch and adjusted for iwd support] https://mail.gnome.org/archives/networkmanager-list/2017-December/msg00022.html
Diffstat (limited to 'src/devices/bluetooth/meson.build')
-rw-r--r--src/devices/bluetooth/meson.build51
1 files changed, 51 insertions, 0 deletions
diff --git a/src/devices/bluetooth/meson.build b/src/devices/bluetooth/meson.build
new file mode 100644
index 0000000000..2e59810dfa
--- /dev/null
+++ b/src/devices/bluetooth/meson.build
@@ -0,0 +1,51 @@
+sources = files(
+ 'nm-bluez-device.c',
+ 'nm-bluez-manager.c',
+ 'nm-bluez4-adapter.c',
+ 'nm-bluez4-manager.c',
+ 'nm-bluez5-manager.c',
+ 'nm-bt-error.c',
+ 'nm-device-bt.c'
+)
+
+deps = [
+ core_dep,
+ libnm_wwan_dep,
+ libnmdbus_dep
+]
+
+ldflags = []
+if have_version_script
+ ldflags += '-Wl,--version-script,@0@'.format(linker_script_devices)
+endif
+
+if enable_bluez5_dun
+ sources += files('nm-bluez5-dun.c')
+
+ deps += bluez5_dep
+endif
+
+libnm_device_plugin_bluetooth = shared_module(
+ 'nm-device-plugin-bluetooth',
+ sources: sources,
+ dependencies: deps,
+ link_args: ldflags,
+ link_depends: linker_script_devices,
+ install: true,
+ install_dir: nm_pkglibdir
+)
+
+core_plugins += libnm_device_plugin_bluetooth
+
+run_target(
+ 'check-local-devices-bluetooth',
+ command: [check_exports, libnm_device_plugin_bluetooth.full_path(), linker_script_devices],
+ depends: libnm_device_plugin_bluetooth
+)
+
+# FIXME: check_so_symbols replacement
+'''
+check-local-devices-bluetooth: src/devices/bluetooth/libnm-device-plugin-bluetooth.la
+ $(srcdir)/tools/check-exports.sh $(builddir)/src/devices/bluetooth/.libs/libnm-device-plugin-bluetooth.so "$(srcdir)/linker-script-devices.ver"
+ $(call check_so_symbols,$(builddir)/src/devices/bluetooth/.libs/libnm-device-plugin-bluetooth.so)
+'''