summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@redhat.com>2015-01-12 11:31:10 -0500
committerDan Winship <danw@redhat.com>2015-01-19 11:29:13 -0500
commitc5b3e93792ed4feadf9bf50c43bc6d0c3739c354 (patch)
treebdd8ab844831c13955f0a9a195f787efb89545b4 /src/Makefile.am
parent1c435dc87478d0bd917f555d16f1ad7dbf6c1e96 (diff)
downloadNetworkManager-c5b3e93792ed4feadf9bf50c43bc6d0c3739c354.tar.gz
core: use GUnixSignalWatchSource to simplify signal handling
Replace the pthread_sigwait()-based signal handling with g_unix_signal_add()-based handling, and get rid of all the now-unnecessary calls to nm_unblock_posix_signals() when spawning subprocesses. As a bonus, this also fixes the "^C in gdb kills NM too" bug.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e9cedd9d67..b8e4c36b38 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -320,8 +320,6 @@ nm_sources = \
nm-manager.h \
nm-policy.c \
nm-policy.h \
- nm-posix-signals.c \
- nm-posix-signals.h \
nm-properties-changed-signal.c \
nm-properties-changed-signal.h \
nm-rfkill-manager.c \
@@ -481,8 +479,6 @@ libnm_iface_helper_la_SOURCES = \
nm-enum-types.h \
nm-logging.c \
nm-logging.h \
- nm-posix-signals.c \
- nm-posix-signals.h \
NetworkManagerUtils.c \
NetworkManagerUtils.h