summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2015-09-16 15:49:02 +0200
committerThomas Haller <thaller@redhat.com>2015-09-16 16:54:51 +0200
commit3ba1c8e297af0e66eaf40ff1d33e1c1087efa685 (patch)
tree428b8de23f4e162d64ff0bcb59d5bc70be6c7446 /src/Makefile.am
parentc05557971c09782316ee7e39ae4e7a7675d338f1 (diff)
downloadNetworkManager-3ba1c8e297af0e66eaf40ff1d33e1c1087efa685.tar.gz
systemd/build: use separate NETWORKMANAGER_COMPILATION define for systemd build
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 220331cff5..61e4c2a4a2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -62,8 +62,7 @@ SYSTEMD_NM_CFLAGS = \
-I$(top_srcdir)/src/systemd/src/shared \
-I$(top_srcdir)/src/systemd \
-I$(top_srcdir)/libnm-core \
- -I$(top_builddir)/libnm-core \
- -DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_INSIDE_DAEMON
+ -I$(top_builddir)/libnm-core
libsystemd_nm_la_SOURCES = \
systemd/nm-sd-adapt.c \
@@ -135,6 +134,7 @@ libsystemd_nm_la_SOURCES = \
libsystemd_nm_la_CPPFLAGS = \
-I$(top_srcdir)/include \
$(SYSTEMD_NM_CFLAGS) \
+ -DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_SYSTEMD \
$(GLIB_CFLAGS)
libsystemd_nm_la_LIBADD = \