summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorEric Koegel <eric.koegel@gmail.com>2015-07-24 19:47:29 +0300
committerThomas Haller <thaller@redhat.com>2015-08-07 11:45:57 +0200
commit0db81e10145a55e0e17af28baeba91e5167aac12 (patch)
tree385548d25eaf18af01c220ebf1c0b7cfb2f13ed3 /src/Makefile.am
parent558117222fabd8244e3d01e281c6391967b273c3 (diff)
downloadNetworkManager-0db81e10145a55e0e17af28baeba91e5167aac12.tar.gz
sleep-monitor: add support for ConsoleKit2 inhibit
ConsoleKit2 has added the same suspend/resume DBUS API that Systemd uses. This patch adds the code to use ConsoleKit2's inhibit API. http://consolekit2.github.io/ConsoleKit2/#Manager.Inhibit [thaller@redhat.com: modified original patch] https://bugzilla.gnome.org/show_bug.cgi?id=752836
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d8e9327a3b..fbd64722ec 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -361,11 +361,11 @@ nm_sources = \
NetworkManagerUtils.h
-if SUSPEND_RESUME_SYSTEMD
-nm_sources += nm-sleep-monitor-systemd.c
-else
-# UPower suspend/resume used whenever systemd is not enabled
+if SUSPEND_RESUME_UPOWER
nm_sources += nm-sleep-monitor-upower.c
+else
+# systemd/consolekit suspend/resume used whenever upower is not enabled
+nm_sources += nm-sleep-monitor-systemd.c
endif
if WITH_WEXT