summaryrefslogtreecommitdiff
path: root/shared/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-10-12 18:05:48 +0200
committerThomas Haller <thaller@redhat.com>2018-10-18 12:16:55 +0200
commitdfdbd1b385aa48a4c128283ae2b3234885808f5a (patch)
treee271c698a984244c8c42c78e3d001e66cb793577 /shared/meson.build
parenta6add8175a150f9bf64ac0b27064dc0d736aea6a (diff)
downloadNetworkManager-dfdbd1b385aa48a4c128283ae2b3234885808f5a.tar.gz
shared/tests: add test for "shared/nm-utils"
"shared/nm-utils" is a loose collection of utility functions. There is a certain aim that they can be used independently. However, they also rely on each other. Add a test that we can build a minimal shared library with these tools, independent of libnm-core.
Diffstat (limited to 'shared/meson.build')
-rw-r--r--shared/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/shared/meson.build b/shared/meson.build
index 9afc9a6d56..274bc736f9 100644
--- a/shared/meson.build
+++ b/shared/meson.build
@@ -117,3 +117,31 @@ shared_dep = declare_dependency(
],
dependencies: glib_dep,
)
+
+###############################################################################
+
+test_shared_general = executable(
+ 'nm-utils/tests/test-shared-general',
+ [ 'nm-utils/tests/test-shared-general.c',
+ 'nm-utils/c-list-util.c',
+ 'nm-utils/nm-dedup-multi.c',
+ 'nm-utils/nm-enum-utils.c',
+ 'nm-utils/nm-hash-utils.c',
+ 'nm-utils/nm-io-utils.c',
+ 'nm-utils/nm-random-utils.c',
+ 'nm-utils/nm-secret-utils.c',
+ 'nm-utils/nm-shared-utils.c',
+ 'nm-utils/nm-time-utils.c',
+ ],
+ c_args: [
+ '-DNETWORKMANAGER_COMPILATION_TEST',
+ '-DNETWORKMANAGER_COMPILATION=(NM_NETWORKMANAGER_COMPILATION_GLIB|NM_NETWORKMANAGER_COMPILATION_WITH_GLIB_I18N_PROG)',
+ ],
+ dependencies: shared_dep,
+ link_with: shared_c_siphash,
+)
+test(
+ 'shared/nm-utils/test-shared-general',
+ test_script,
+ args: test_args + [test_shared_general.full_path()]
+)