summaryrefslogtreecommitdiff
path: root/shared/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-08-28 21:20:36 +0200
committerThomas Haller <thaller@redhat.com>2018-09-04 07:38:30 +0200
commitb232508707e7bca57edd926e13cd2d211afe3df5 (patch)
tree4c89e0aab6d461f90079b5c3e9b11c07d67e85cb /shared/meson.build
parent74815fd8e023c2a3713129fe906b83c856248adf (diff)
downloadNetworkManager-b232508707e7bca57edd926e13cd2d211afe3df5.tar.gz
shared: add nm-secret-utils.h helper
We already had nm_free_secret() to clear the secret out of a NUL terminated string. That works well for secrets which are strings, it can be used with a cleanup attribute (nm_auto_free_secret) and as a cleanup function for a GBytes. However, it does not work for secrets which are binary. For those, we must also track the length of the allocated data and clear it. Add two new structs NMSecretPtr and NMSecretBuf to help with that.
Diffstat (limited to 'shared/meson.build')
-rw-r--r--shared/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/shared/meson.build b/shared/meson.build
index 8faec8765b..c14b9d723b 100644
--- a/shared/meson.build
+++ b/shared/meson.build
@@ -51,6 +51,7 @@ shared_files_libnm_core = files('''
nm-utils/nm-enum-utils.c
nm-utils/nm-hash-utils.c
nm-utils/nm-random-utils.c
+ nm-utils/nm-secret-utils.c
nm-utils/nm-shared-utils.c
nm-utils/nm-udev-utils.c
'''.split())