summaryrefslogtreecommitdiff
path: root/shared/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-09-02 07:54:28 +0200
committerThomas Haller <thaller@redhat.com>2019-09-21 14:58:26 +0200
commit908fadec964e028b3be3382a74d535b3c3324e2f (patch)
treefd45bed58be9cd11598252d05b1f20f6a8554b08 /shared/meson.build
parentdd33b3a14e9cbae66f51cbad3c6e42388b43f7c1 (diff)
downloadNetworkManager-908fadec964e028b3be3382a74d535b3c3324e2f.tar.gz
shared: add NMRefString
I'd like to refactor libnm's caching. Note that cached D-Bus objects have repeated strings all over the place. For example every object will have a set of D-Bus interfaces (strings) and properties (strings) and an object path (which is referenced by other objects). We can save a lot of redundant strings by deduplicating/interning them. Also, by interning them, we can compare them using pointer equality. Add a NMRefString implementation for this. Maybe an alternative name would be NMInternedString or NMDedupString, because this string gets always interned. There is no way to create a NMRefString that is not interned. Still, NMRefString name sounds better. It is ref-counted after all. Notes: - glib has GQuark and g_intern_string(). However, such strings cannot be unrefered and are leaked indefinitely. It is thus unsuited for anything but a fixed set of well-known strings. - glib 2.58 adds GRefString, but we cannot use that because we currently still use glib 2.40. There are some differences: - GRefString is just a typedef to char. That means, the glib API exposes GRefString like regular character strings. NMRefString intentionally does that not. This makes it slightly less convenient to pass it to API that expects "const char *". But it makes it clear to the reader, that an instance is in fact a NMRefString, which means it indicates that the string is interned and can be referenced without additional copy. - GRefString can be optionally interned. That means you can only use pointer equality for comparing values if you know that the GRefString was created with g_ref_string_new_intern(). So, GRefString looks like a "const char *" pointer and even if you know it's a GRefString, you might not know whether it is interned. NMRefString is always interned, and you can always compare it using pointer equality. - In the past I already proposed a different implementation for a ref-string. That made different choices. For example NMRefString then was a typedef to "const char *", it did not support interning but deduplication (without a global cache), ref/unref was not thread safe (but then there was no global cache so that two threads could still use the API independently). The point is, there are various choices to make. GRefString, the previous NMRefString implementation and the one here, all have pros and cons. I think for the purpose where I intend NMRefString (dedup and efficient comparison), it is a preferable implementation. Ah, and of course NMRefString is an immutable string, which is a nice property.
Diffstat (limited to 'shared/meson.build')
-rw-r--r--shared/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/shared/meson.build b/shared/meson.build
index d542804eb4..aa10f792f8 100644
--- a/shared/meson.build
+++ b/shared/meson.build
@@ -185,6 +185,7 @@ shared_nm_glib_aux = static_library(
'nm-glib-aux/nm-json-aux.c',
'nm-glib-aux/nm-keyfile-aux.c',
'nm-glib-aux/nm-random-utils.c',
+ 'nm-glib-aux/nm-ref-string.c',
'nm-glib-aux/nm-secret-utils.c',
'nm-glib-aux/nm-shared-utils.c',
'nm-glib-aux/nm-time-utils.c'),