summaryrefslogtreecommitdiff
path: root/shared/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-04-21 10:11:16 +0200
committerThomas Haller <thaller@redhat.com>2019-04-25 07:47:37 +0200
commit7a25f67af79c1732e3b450e4e274630327832e09 (patch)
tree8554907ef3c462e7d5a6431c67b7d7fa52134d3e /shared/meson.build
parent911f2dfe5658b09b6b55b2ffba060272c694922a (diff)
downloadNetworkManager-7a25f67af79c1732e3b450e4e274630327832e09.tar.gz
shared/tests: add tests for libnm-core-aux
These tests cannot (easily) be under "shared/nm-libnm-core-aux/tests" because libnm/libnm-core requires code under shared while "nm-libnm-core-aux" requires libnm/libnm-core. With autotools that is not problem, but with meson we include sub directories in a particular order and there is no way to foward declare stuff (AFAIK). To avoid the circular dependency, add the tests to "clients/common/tests", which is always built last.
Diffstat (limited to 'shared/meson.build')
-rw-r--r--shared/meson.build25
1 files changed, 14 insertions, 11 deletions
diff --git a/shared/meson.build b/shared/meson.build
index 380758f00f..ba4c28c3fd 100644
--- a/shared/meson.build
+++ b/shared/meson.build
@@ -287,18 +287,21 @@ libnm_systemd_shared_no_logging_dep = declare_dependency(
###############################################################################
-test_shared_general = executable(
- 'nm-utils/tests/test-shared-general',
- [ 'nm-utils/tests/test-shared-general.c', ],
- c_args: [
- '-DNETWORKMANAGER_COMPILATION_TEST',
- '-DNETWORKMANAGER_COMPILATION=(NM_NETWORKMANAGER_COMPILATION_GLIB|NM_NETWORKMANAGER_COMPILATION_WITH_GLIB_I18N_PROG)',
+exe = executable(
+ 'nm-utils/tests/test-shared-general',
+ [ 'nm-utils/tests/test-shared-general.c' ],
+ c_args: [
+ '-DNETWORKMANAGER_COMPILATION_TEST',
+ '-DNETWORKMANAGER_COMPILATION=(NM_NETWORKMANAGER_COMPILATION_GLIB|NM_NETWORKMANAGER_COMPILATION_WITH_GLIB_I18N_PROG)',
+ ],
+ dependencies: [
+ shared_nm_glib_aux_dep,
+ shared_c_siphash_dep,
],
- dependencies: shared_nm_glib_aux_dep,
- link_with: shared_c_siphash,
)
+
test(
- 'shared/nm-utils/test-shared-general',
- test_script,
- args: test_args + [test_shared_general.full_path()]
+ 'shared/nm-utils/tests/test-shared-general',
+ test_script,
+ args: test_args + [exe.full_path()]
)