summaryrefslogtreecommitdiff
path: root/shared/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2017-11-25 11:39:06 +0100
committerThomas Haller <thaller@redhat.com>2017-12-13 15:48:50 +0100
commit03637ad8b5d21fcc12a536a25caf46445aabde73 (patch)
tree3330fed2a9ad0f45c0c993a8aac6d3dee42ed101 /shared/meson.build
parente96fabfc186510808cee1bf6aaaa28f460f1cea5 (diff)
downloadNetworkManager-03637ad8b5d21fcc12a536a25caf46445aabde73.tar.gz
build: add initial support for meson build system
meson is a build system focused on speed an ease of use, which helps speeding up the software development. This patch adds meson support along autotools. [thaller@redhat.com: rebased patch and adjusted for iwd support] https://mail.gnome.org/archives/networkmanager-list/2017-December/msg00022.html
Diffstat (limited to 'shared/meson.build')
-rw-r--r--shared/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/shared/meson.build b/shared/meson.build
new file mode 100644
index 0000000000..d3c1df0dff
--- /dev/null
+++ b/shared/meson.build
@@ -0,0 +1,39 @@
+shared_inc = include_directories(
+ '.',
+ 'nm-utils'
+)
+
+version_conf = configuration_data()
+version_conf.set('NM_MAJOR_VERSION', nm_major_version)
+version_conf.set('NM_MINOR_VERSION', nm_minor_version)
+version_conf.set('NM_MICRO_VERSION', nm_micro_version)
+
+version = 'nm-version-macros.h'
+
+version_header = configure_file(
+ input: version + '.in',
+ output: version,
+ configuration: version_conf
+)
+
+shared_meta_setting = files('nm-meta-setting.c')
+
+shared_test_utils = files('nm-test-utils-impl.c')
+
+shared_siphash = files('nm-utils/siphash24.c')
+
+shared_udev_utils = files('nm-utils/nm-udev-utils.c')
+
+shared_utils = files(
+ 'nm-utils/nm-enum-utils.c',
+ 'nm-utils/nm-hash-utils.c',
+ 'nm-utils/nm-random-utils.c',
+ 'nm-utils/nm-shared-utils.c'
+)
+
+shared_vpn_plugin_utils = files('nm-utils/nm-vpn-plugin-utils.c')
+
+shared_sources = shared_utils + shared_meta_setting + shared_udev_utils + files(
+ 'nm-utils/c-list-util.c',
+ 'nm-utils/nm-dedup-multi.c'
+)