summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-04-19 07:29:14 +0200
committerThomas Haller <thaller@redhat.com>2019-04-19 07:34:41 +0200
commitfdac4b3bcf2ce4204578c6a12adc7d0dc8bf1115 (patch)
tree3617cb963b1085e9c5e62a0cf7c80775ff65c9b7 /meson.build
parent51aee380c0dc572a809d8ad720f4138d87cac272 (diff)
downloadNetworkManager-fdac4b3bcf2ce4204578c6a12adc7d0dc8bf1115.tar.gz
build/meson: skip building fake-typelib if gnome.compile_resources() too old
Otherwise, the meson configure step fails with: libnm/fake-typelib/meson.build:23:0: ERROR: The "dependencies" argument of gnome.compile_resources() can not be used with the current version of glib-compile-resources due to <https://bugzilla.gnome.org/show_bug.cgi?id=774368> The fake-typelib is not really essential. Don't fix it, just print a warning that we are unable to build it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index aa32046f53..91950142e9 100644
--- a/meson.build
+++ b/meson.build
@@ -327,6 +327,11 @@ if enable_libnm_glib
endif
# FIXME: do this better!!!
have_fake_typelibs = enable_libnm_glib and enable_introspection
+if have_fake_typelibs and gio_unix_dep.version().version_compare('< 2.51.1')
+ warning('cannot build fake typelibs for libnm because glib is too old')
+ have_fake_typelibs=false
+endif
+
config_h.set10('WITH_FAKE_TYPELIBS', have_fake_typelibs)
udev_dir = get_option('udev_dir')