summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorFabrice Fontaine <fontaine.fabrice@gmail.com>2023-02-21 13:03:00 +0100
committerThomas Haller <thaller@redhat.com>2023-02-21 14:56:15 +0100
commit3a3ac89b537c2081b91ba074d52c1fd6685d958c (patch)
tree9d5a4f781ded5769c7223b297ffa4f5c39cf4734 /meson.build
parent34417ac3e637020f9c1f51906a23491a9e14be31 (diff)
downloadNetworkManager-3a3ac89b537c2081b91ba074d52c1fd6685d958c.tar.gz
meson.build: fix build failure with -Dmodem_manager=false
Fix the following build failure with -Dmodem_manager=false raised since commit 03ba04d4784f ('build: meson: add option to set the mobile-broadband-provider-info database'). ../output-1/build/network-manager-1.40.10/meson.build:1060:0: ERROR: Unknown variable "mobile_broadband_provider_info_database". http://autobuild.buildroot.org/results/896879c8e8ce022556ee834216ced2f962ff279c Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Fixes: 03ba04d4784f ('build: meson: add option to set the mobile-broadband-provider-info database') https://gitlab.freedesktop.org/NetworkManager/NetworkManager/-/merge_requests/1544
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 84ce52c736..b79240efc0 100644
--- a/meson.build
+++ b/meson.build
@@ -1057,7 +1057,9 @@ output += ' jansson: ' + jansson_msg + '\n'
output += ' iptables: ' + config_h.get('IPTABLES_PATH') + '\n'
output += ' nft: ' + config_h.get('NFT_PATH') + '\n'
output += ' modemmanager-1: ' + enable_modem_manager.to_string() + '\n'
-output += ' mobile-broadband-provider-info-database: ' + mobile_broadband_provider_info_database + '\n'
+if enable_modem_manager
+ output += ' mobile-broadband-provider-info-database: ' + mobile_broadband_provider_info_database + '\n'
+endif
output += ' ofono: ' + enable_ofono.to_string() + '\n'
output += ' concheck: ' + enable_concheck.to_string() + '\n'
output += ' libteamdctl: ' + enable_teamdctl.to_string() + '\n'