summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorIñigo Martínez <inigomartinez@gmail.com>2018-10-12 10:02:10 +0200
committerThomas Haller <thaller@redhat.com>2018-12-20 13:50:34 +0100
commit282af18e16d382fe5cfc0cdd71c882e9b1d40fa2 (patch)
tree6813360f4cfd2024731c147726310c009c21e34c /meson.build
parent35171b3c3f850a9136e48d12ead389ee80842268 (diff)
downloadNetworkManager-282af18e16d382fe5cfc0cdd71c882e9b1d40fa2.tar.gz
build: meson: Remove unnecessary auxiliary variable
The variable containing the list of compiler arguments to be checked can be removed without any harm to readibility. The variable has been removed by appending directly to the list of common compiler arguments, those that are supported.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 6b0e1eebe6..034b7827f1 100644
--- a/meson.build
+++ b/meson.build
@@ -148,7 +148,7 @@ if enable_ld_gc
endif
if nm_debug
- test_cflags = [
+ common_flags += cc.get_supported_arguments([
'-fno-strict-aliasing',
'-Wdeclaration-after-statement',
'-Wfloat-equal',
@@ -172,9 +172,7 @@ if nm_debug
'-Wtypedef-redefinition',
'-Wundef',
'-Wunknown-attributes',
- ]
-
- common_flags += cc.get_supported_arguments(test_cflags)
+ ])
endif
add_project_arguments(common_flags, language: 'c')