summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2022-05-11 22:29:06 +0200
committerThomas Haller <thaller@redhat.com>2022-05-11 22:34:38 +0200
commit1a995325d51106fd819d453a8ca7c73cc80ae6dd (patch)
treef34e3f7b5b743f7909b88f03f5c2e1f83976e8c1 /meson.build
parentf6f961f381f72adb4d391a1a55c0dbd6c8a22fc7 (diff)
downloadNetworkManager-1a995325d51106fd819d453a8ca7c73cc80ae6dd.tar.gz
build/meson: workaround meson bug related to ternary expression
On Debian 10, `apt-get install meson` gives meson-0.49.2-1. That version doesn't like certain ternary expressions (while some that we have are OK), which leads to a crash of meson. Avoid that. Fixes: bddffb1731c7 ('build/meson: honor prefix for udev_dir and don't use pkg-config')
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index a4814550ae..f07408c1a5 100644
--- a/meson.build
+++ b/meson.build
@@ -355,7 +355,6 @@ endif
udev_udevdir = get_option('udev_dir')
if udev_udevdir == 'no'
install_udevdir = false
- udev_udevdir = ''
else
install_udevdir = true
if (udev_udevdir == '' or udev_udevdir == 'yes')
@@ -1018,7 +1017,7 @@ output = '\nSystem paths:\n'
output += ' prefix: ' + nm_prefix + '\n'
output += ' exec_prefix: ' + nm_prefix + '\n'
output += ' systemdunitdir: ' + systemd_systemdsystemunitdir + '\n'
-output += ' udev_dir: ' + (install_udevdir ? udev_udevdir : '(none)') + '\n'
+output += ' udev_dir: ' + udev_udevdir + '\n'
output += ' nmbinary: ' + nm_pkgsbindir + '\n'
output += ' nmconfdir: ' + nm_pkgconfdir + '\n'
output += ' nmlibdir: ' + nm_pkglibdir + '\n'