summaryrefslogtreecommitdiff
path: root/data/meson.build
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2015-03-29 22:57:50 +0200
committerLubomir Rintel <lkundrak@v3.sk>2018-10-12 12:54:02 +0200
commit90f71c0f99b006df8135cf76ac8a44308f954450 (patch)
treef866f0d936d52192917d853784058a9591299304 /data/meson.build
parentcec7ade86c2ac2a20a5b3cdabcf375ece347dd76 (diff)
downloadNetworkManager-90f71c0f99b006df8135cf76ac8a44308f954450.tar.gz
systemd: don't make NetworkManager D-Bus activatable
If the NetworkManager daemon has been stopped manually we don't want it to be autostarted by a client request. [lkundrak@v3.sk: The auto-activation is probably more surprising than useful. Services that need NetworkManager API should depend on NetworkManager service directly. I have no idea what purpose does the D-Bus service file serve nowadays, but it looks rather hacky (really, activating /bin/false) and the comment in it suggests that the autoactivating behavior was not intended anyway. Debian has been shipping this for quite some time and no complains have been heard.] https://github.com/NetworkManager/NetworkManager/pull/230
Diffstat (limited to 'data/meson.build')
-rw-r--r--data/meson.build15
1 files changed, 7 insertions, 8 deletions
diff --git a/data/meson.build b/data/meson.build
index 636db92197..593809d820 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -18,23 +18,22 @@ configure_file(
if install_systemd_unit_dir
services = [
- ['NetworkManager-dispatcher.service', systemd_system_unit_dir],
- ['NetworkManager.service', systemd_system_unit_dir],
- ['org.freedesktop.NetworkManager.service', dbus_sys_dir]
+ 'NetworkManager-dispatcher.service',
+ 'NetworkManager.service',
]
if have_systemd_200
- services += [['NetworkManager-wait-online.service', systemd_system_unit_dir]]
+ services += ['NetworkManager-wait-online.service']
else
- services += [['NetworkManager-wait-online-systemd-pre200.service', systemd_system_unit_dir]]
+ services += ['NetworkManager-wait-online-systemd-pre200.service']
endif
foreach service: services
configure_file(
- input: service[0] + '.in',
- output: service[0],
+ input: service + '.in',
+ output: service,
install: true,
- install_dir: service[1],
+ install_dir: systemd_system_unit_dir,
configuration: data_conf
)
endforeach