summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLubomir Rintel <lkundrak@v3.sk>2023-03-02 19:35:38 +0100
committerLubomir Rintel <lkundrak@v3.sk>2023-03-21 23:35:42 +0100
commitd89d42bf23170b4923f71bc415fe071f7c03978a (patch)
tree4c56af7e6736d71e28bc30c0114af7737ccfe16b /Makefile.am
parentad6878d50a10c0a6d0c36c3487d41ebce5f2ee74 (diff)
downloadNetworkManager-d89d42bf23170b4923f71bc415fe071f7c03978a.tar.gz
tests/client: test nm-cloud-setup
Some fairly rudimentary testing of nm-cloud-setup.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0f827c6763..cd30c7201e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5472,6 +5472,13 @@ check-local-tests-client: src/nmcli/nmcli src/tests/client/test-client.py
check_local += check-local-tests-client
+check-local-tests-cloud-setup: src/nm-cloud-setup/nm-cloud-setup src/tests/client/test-client.py
+ LIBTOOL="$(LIBTOOL)" "$(srcdir)/src/tests/client/test-client.sh" "$(builddir)" "$(srcdir)" "$(PYTHON)" -- TestNmCloudSetup
+
+if BUILD_NM_CLOUD_SETUP
+check_local += check-local-tests-cloud-setup
+endif
+
CLEANFILES += src/tests/client/test-client.log
EXTRA_DIST += \