summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Love <rml@novell.com>2005-06-20 17:16:51 +0000
committerRobert Love <rlove@rlove.org>2005-06-20 17:16:51 +0000
commitd6b8f804695d96b28fe7c346cdb69dbf40561a8f (patch)
treeb9182fb34078f4d56c9d89725f63b811285af4c6 /Makefile.am
parenta4e36e42130c0682a3f58119f104069c050571b6 (diff)
downloadNetworkManager-d6b8f804695d96b28fe7c346cdb69dbf40561a8f.tar.gz
2005-06-20 Robert Love <rml@novell.com>
* Makefile.am: Add missing intltool-foo.in generated files to EXTRA_DIST so that 'distcheck' works. Also add DISTCLEANFILES with the start of stuff to cleanup on 'distclea'. * configure.in: add AC_PROG_INTLTOOL macro so that we do the intltool stuff right and 'distcheck' works. * po/POTFILES.in: Remove examples/python/systray/eggtrayicon.c. If we keep it, we need to add all of examples/* to EXTRA_DIST and do Makefile.am for each. And systray/Makefile needs to be redone. git-svn-id: http://svn-archive.gnome.org/svn/NetworkManager/trunk@725 4912f4e0-d625-0410-9fb7-b9a5a253dbdc
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 99e0252fe2..02504ed123 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,14 @@
SUBDIRS = utils src dispatcher-daemon gnome initscript test po
-EXTRA_DIST = CONTRIBUTING NetworkManager.pc.in NetworkManager.h
+EXTRA_DIST = \
+ CONTRIBUTING \
+ NetworkManager.pc.in \
+ NetworkManager.h \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in
+
+DISTCLEANFILES = intltool-extract intltool-merge intltool-update
pkgconfigdir = $(libdir)/pkgconfig