summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2022-09-20 12:38:03 +0200
committerThomas Haller <thaller@redhat.com>2022-09-23 11:43:34 +0200
commitaea053db38ffd00c223e5cc1b5d3f2b342fc9870 (patch)
treed739f585cce6af2d0a0fd9b357c74cd644f42761 /Makefile.am
parent231671fd02352773cd7a3274f99a825052c66a26 (diff)
downloadNetworkManager-aea053db38ffd00c223e5cc1b5d3f2b342fc9870.tar.gz
platform: add "nmp-plobj.[hc]"
Our naming in libnm-platform is bad. We have NMPlatform, which is a cache of objects. Consequently we have platform methods like nm_platform_get_link(). We also have various other types that share the NMPlatform prefix, like NMPlatformIP4Address. For those we have nm_platform_ip4_address_to_string(). "methods" of a type should have the same prefix as the type, and we should not have types that share the same prefix. Also, "NMPlatformIP4Address" is a long name, and inconsistent with the strongly related NMPObjectIP4Address. Add new files to move and rename parts of the platform API.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 843ad3cfcb..11450fdda2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -614,6 +614,8 @@ src_libnm_platform_libnm_platform_la_SOURCES = \
src/libnm-platform/nmp-netns.h \
src/libnm-platform/nmp-object.c \
src/libnm-platform/nmp-object.h \
+ src/libnm-platform/nmp-plobj.c \
+ src/libnm-platform/nmp-plobj.h \
src/libnm-platform/wifi/nm-wifi-utils-nl80211.c \
src/libnm-platform/wifi/nm-wifi-utils-nl80211.h \
src/libnm-platform/wifi/nm-wifi-utils-private.h \