summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-10-17 08:41:01 +0200
committerThomas Haller <thaller@redhat.com>2019-10-18 22:09:18 +0200
commit8f37a0ae0ab8518689d7f2381c1a77468016b238 (patch)
tree0dc462715ffe0e572f8281a2dc3cc49757820c3b /Makefile.am
parent69de5ee4e9929159954a5b6ecadd0eb9a5a287ae (diff)
downloadNetworkManager-8f37a0ae0ab8518689d7f2381c1a77468016b238.tar.gz
build: link "nm-enum-types.c" with the base "liblibnm" instead of "libnm"
This way the symbols are also available to the unit tests.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index c38da77c60..dde8a7b03c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -748,6 +748,7 @@ CLEANFILES += $(DBUS_INTERFACE_DOCS)
$(dispatcher_libnm_dispatcher_core_la_OBJECTS): $(introspection_sources)
$(dispatcher_nm_dispatcher_OBJECTS): $(introspection_sources)
+$(libnm_liblibnm_la_OBJECTS): $(introspection_sources)
$(libnm_libnm_la_OBJECTS): $(introspection_sources)
EXTRA_DIST += \
@@ -1327,6 +1328,11 @@ libnm_liblibnm_la_SOURCES = \
$(libnm_lib_c_real) \
$(NULL)
+nodist_libnm_liblibnm_la_SOURCES = \
+ $(libnm_lib_h_pub_mkenums) \
+ $(libnm_lib_c_mkenums) \
+ $(NULL)
+
libnm_liblibnm_la_LIBADD = \
shared/nm-libnm-core-aux/libnm-libnm-core-aux.la \
libnm-core/libnm-core.la \
@@ -1377,11 +1383,6 @@ libnm_libnm_la_SOURCES = \
$(libnm_lib_h_priv) \
$(NULL)
-nodist_libnm_libnm_la_SOURCES = \
- $(libnm_lib_h_pub_mkenums) \
- $(libnm_lib_c_mkenums) \
- $(NULL)
-
EXTRA_libnm_libnm_la_DEPENDENCIES = \
libnm/libnm.ver