summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2018-09-04 10:50:40 +0200
committerBeniamino Galvani <bgalvani@redhat.com>2018-09-18 15:15:34 +0200
commit88072c66210719f5515700a47b3699d28c71a7c6 (patch)
tree38e2b5d778747b99f87f5bb16439e084c35b6884 /Makefile.am
parent51776b297e04dabb24b7b645744da7100f85ff2e (diff)
downloadNetworkManager-88072c66210719f5515700a47b3699d28c71a7c6.tar.gz
build: compile the c-rbtree library
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b0feefa40..dddd7026a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1347,6 +1347,22 @@ shared_libcsiphash_la_SOURCES = \
###############################################################################
+noinst_LTLIBRARIES += shared/libcrbtree.la
+
+shared_libcrbtree_la_CFLAGS = $(AM_CFLAGS) -std=c11
+
+shared_libcrbtree_la_CPPFLAGS = \
+ $(CODE_COVERAGE_CFLAGS) \
+ $(SANITIZER_LIB_CFLAGS) \
+ $(NULL)
+
+shared_libcrbtree_la_SOURCES = \
+ shared/c-rbtree/src/c-rbtree.c \
+ shared/c-rbtree/src/c-rbtree.h \
+ shared/c-rbtree/src/c-rbtree-private.h
+
+###############################################################################
+
noinst_LTLIBRARIES += shared/libnacd.la
shared_libnacd_la_CFLAGS = -std=gnu99