summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBeniamino Galvani <bgalvani@redhat.com>2018-12-06 15:36:55 +0100
committerBeniamino Galvani <bgalvani@redhat.com>2018-12-12 14:38:18 +0100
commit81bc218e6d46dcbc798550a7657734c5b3e50181 (patch)
treeeaa09240101e8fe108babeeb8c3652e16d5849b3 /Makefile.am
parentf606124b6212e7d6cc005ff0147e63a30da09586 (diff)
downloadNetworkManager-81bc218e6d46dcbc798550a7657734c5b3e50181.tar.gz
meson: add check on settings docs
Move the autotools check on settings docs to a shell script and call it from meson too.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 2 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index d298e54d91..68f4f0a28e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3833,16 +3833,7 @@ $(clients_common_settings_doc_h): clients/common/settings-docs.xsl libnm/nm-prop
$(AM_V_GEN) $(XSLTPROC) --output $@ $< $(word 2,$^)
DISTCLEANFILES += $(clients_common_settings_doc_h)
check-local-settings-docs: $(clients_common_settings_doc_h)
- @if test -z "$$NMTST_NO_CHECK_SETTINGS_DOCS" ; then \
- if ! cmp -s "$(srcdir)/$(clients_common_settings_doc_h).in" "$(builddir)/$(clients_common_settings_doc_h)" ; then \
- if test "$$NM_TEST_REGENERATE" == 1 ; then \
- cp -f "$(builddir)/$(clients_common_settings_doc_h)" "$(srcdir)/$(clients_common_settings_doc_h).in"; \
- else \
- echo "The generated file \"$(builddir)/$(clients_common_settings_doc_h)\" differs from the source file \"$(srcdir)/$(clients_common_settings_doc_h).in\". You probably should copy the generated file over to the source file. You can skip this test by setting \$$NMTST_NO_CHECK_SETTINGS_DOCS=yes". You can also automatically copy the file by rerunning the test with \$$NM_TEST_REGENERATE=1 ; \
- false; \
- fi; \
- fi;\
- fi
+ $(srcdir)/tools/check-settings-docs.sh "$(srcdir)" "$(builddir)" "$(clients_common_settings_doc_h)"
check_local += check-local-settings-docs
else
$(clients_common_settings_doc_h): $(clients_common_settings_doc_h).in clients/common/.dirstamp
@@ -5166,6 +5157,7 @@ EXTRA_DIST += \
tools/check-config-options.sh \
tools/check-docs.sh \
tools/check-exports.sh \
+ tools/check-settings-docs.sh \
tools/create-exports-NetworkManager.sh \
tools/debug-helper.py \
tools/meson-post-install.sh \