summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2021-01-09 11:47:22 +0100
committerThomas Haller <thaller@redhat.com>2021-01-15 11:32:39 +0100
commit19242f56d760b1e6e0e9ecee120835f95c7b8d94 (patch)
tree9b8c014930b6a6ee54e2ad2f4e1e156f0ef032ea /Makefile.am
parent9a5a95e0faa32f1c745dc69462cf81b80c4309f8 (diff)
downloadNetworkManager-19242f56d760b1e6e0e9ecee120835f95c7b8d94.tar.gz
libnm: split ethtool option names to a new header "libnm-core/nm-ethtool-utils.h"
We want to use these defines for option names also in "shared/nm-base" (and in turn in "shared/nm-platform), which cannot include "libnm-core". However, they are also public API of libnm. To get this done, in a first step, move these defines to a new header "libnm-core/nm-ethtool-utils.h". Since now the name "nm-ethtool-utils.h" is taken, also rename nm-libnm-core-intern files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f7024a0ee6..b6f84ee29f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -576,8 +576,8 @@ libnm_core_nm_libnm_core_intern_libnm_libnm_core_intern_la_SOURCES = \
libnm-core/nm-libnm-core-intern/nm-auth-subject.c \
libnm-core/nm-libnm-core-intern/nm-auth-subject.h \
libnm-core/nm-libnm-core-intern/nm-common-macros.h \
- libnm-core/nm-libnm-core-intern/nm-ethtool-utils.c \
- libnm-core/nm-libnm-core-intern/nm-ethtool-utils.h \
+ libnm-core/nm-libnm-core-intern/nm-ethtool-base.c \
+ libnm-core/nm-libnm-core-intern/nm-ethtool-base.h \
libnm-core/nm-libnm-core-intern/nm-libnm-core-utils.c \
libnm-core/nm-libnm-core-intern/nm-libnm-core-utils.h \
$(NULL)
@@ -1024,6 +1024,7 @@ libnm_core_lib_h_pub_real = \
libnm-core/nm-core-types.h \
libnm-core/nm-dbus-interface.h \
libnm-core/nm-errors.h \
+ libnm-core/nm-ethtool-utils.h \
libnm-core/nm-keyfile.h \
libnm-core/nm-setting-6lowpan.h \
libnm-core/nm-setting-8021x.h \