summaryrefslogtreecommitdiff
path: root/src/core_dump_handler/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/core_dump_handler/CMakeLists.txt')
-rw-r--r--src/core_dump_handler/CMakeLists.txt39
1 files changed, 21 insertions, 18 deletions
diff --git a/src/core_dump_handler/CMakeLists.txt b/src/core_dump_handler/CMakeLists.txt
index 99cf31a..4545e93 100644
--- a/src/core_dump_handler/CMakeLists.txt
+++ b/src/core_dump_handler/CMakeLists.txt
@@ -15,28 +15,31 @@
# @licence end@
#######
-set( PLATFORM_DIR ${CMAKE_SOURCE_DIR}/src/core_dump_handler/${TARGET_CPU_NAME} )
-set(dlt_cdh_SRCS dlt_cdh.c dlt_cdh_context.c dlt_cdh_coredump.c ${PLATFORM_DIR}/dlt_cdh_cpuinfo.c dlt_cdh_crashid.c dlt_cdh_streamer.c)
+if(WITH_DLT_COREDUMPHANDLER)
-#set(COREDUMP_CONF_DIR "/usr/lib/sysctl.d/")
+ set( PLATFORM_DIR ${CMAKE_SOURCE_DIR}/src/core_dump_handler/${TARGET_CPU_NAME} )
+ set(dlt_cdh_SRCS dlt_cdh.c dlt_cdh_context.c dlt_cdh_coredump.c ${PLATFORM_DIR}/dlt_cdh_cpuinfo.c dlt_cdh_crashid.c dlt_cdh_streamer.c)
-#add_definitions( -fno-strict-aliasing )
+ set(COREDUMP_CONF_DIR "/usr/lib/sysctl.d/")
-if(WITH_CITYHASH)
- set( CITYHASH_DIR ${CMAKE_SOURCE_DIR}/src/core_dump_handler/cityhash_c )
- add_definitions( -DHAS_CITYHASH_C )
- set(dlt_cdh_SRCS ${CITYHASH_DIR}/city_c.c ${dlt_cdh_SRCS} )
-endif(WITH_CITYHASH)
+ #add_definitions( -fno-strict-aliasing )
-add_executable(dlt-cdh ${dlt_cdh_SRCS})
-target_link_libraries(dlt-cdh z)
-set_target_properties(dlt-cdh PROPERTIES LINKER_LANGUAGE C)
+ if(WITH_CITYHASH)
+ set( CITYHASH_DIR ${CMAKE_SOURCE_DIR}/src/core_dump_handler/cityhash_c )
+ add_definitions( -DHAS_CITYHASH_C )
+ set(dlt_cdh_SRCS ${CITYHASH_DIR}/city_c.c ${dlt_cdh_SRCS} )
+ endif(WITH_CITYHASH)
+ add_executable(dlt-cdh ${dlt_cdh_SRCS})
+ target_link_libraries(dlt-cdh z)
+ set_target_properties(dlt-cdh PROPERTIES LINKER_LANGUAGE C)
-install(TARGETS dlt-cdh
- RUNTIME DESTINATION bin
- COMPONENT base)
+ configure_file(${CMAKE_SOURCE_DIR}/src/core_dump_handler/50-coredump.conf.cmake ${PROJECT_BINARY_DIR}/core_dump_handler/50-coredump.conf)
-#install(FILES 50-coredump.conf
-# DESTINATION ${COREDUMP_CONF_DIR}
-# COMPONENT base)
+ install(TARGETS dlt-cdh
+ RUNTIME DESTINATION bin
+ COMPONENT base)
+
+ install(FILES ${PROJECT_BINARY_DIR}/core_dump_handler/50-coredump.conf DESTINATION ${COREDUMP_CONF_DIR} )
+
+endif(WITH_DLT_COREDUMPHANDLER)