summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSaya Sugiura <ssugiura@jp.adit-jv.com>2021-07-28 10:39:38 +0900
committerSaya Sugiura <39760799+ssugiura@users.noreply.github.com>2021-10-05 11:19:26 +0900
commit403246bfbb6eba2569f160ec46d446fc3de5b79d (patch)
treec16caaaf25ab0b81555a755b587677098b8698e3 /CMakeLists.txt
parent9887f590edf9f49421d871d4499cdee55ba7bbd3 (diff)
downloadDLT-daemon-403246bfbb6eba2569f160ec46d446fc3de5b79d.tar.gz
header: Adapt to DLT_DISABLE_MACRO
If dlt.h is included in external application, it needed to include -DDLT_DISABLE_MACRO to make ifdef switch work. This commit adds DLT_DISABLE_MACRO in dlt_user.h so that no additional definition is needed in application. Signed-off-by: Saya Sugiura <ssugiura@jp.adit-jv.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f4bf8df..a45c3c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -156,10 +156,6 @@ if(WITH_DLT_USE_IPv6)
add_definitions(-DDLT_USE_IPv6)
endif()
-if(WITH_DLT_DISABLE_MACRO)
- add_definitions(-DDLT_DISABLE_MACRO)
-endif()
-
if(WITH_DLT_QNX_SYSTEM AND NOT "${CMAKE_C_COMPILER}" MATCHES "nto-qnx|qcc")
message(FATAL_ERROR "Can only compile for QNX with a QNX compiler.")
endif()