summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSaya Sugiura <39760799+ssugiura@users.noreply.github.com>2021-10-05 10:48:48 +0900
committerGitHub <noreply@github.com>2021-10-05 10:48:48 +0900
commit3b339d73aec2a23d45f35b84f2097d63b868dd96 (patch)
tree0632a257c1076bb484ef4eacf9ce664aa6e6646e /CMakeLists.txt
parentd5fd7d9fc253b5dc713bd79dd275b64d26dbe0aa (diff)
downloadDLT-daemon-3b339d73aec2a23d45f35b84f2097d63b868dd96.tar.gz
cmake: Set WITH_LEGACY_INCLUDE_PATH to ON as default (#334)
Signed-off-by: Saya Sugiura <ssugiura@jp.adit-jv.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 915b583..d6377f0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,8 +77,7 @@ option(WITH_DLT_KPI "Set to ON to build src/kpi binaries"
option(WITH_DLT_FATAL_LOG_TRAP "Set to ON to enable DLT_LOG_FATAL trap(trigger segv inside dlt-user library)" OFF)
option(WITH_UDP_CONNECTION "Set to ON to enable dlt UDP multicast SUPPORT" OFF)
option(WITH_LIB_SHORT_VERSION "Set to ON to build library with only major number in version" OFF)
-option(WITH_LEGACY_INCLUDE_PATH "Set to ON to add <prefix>/dlt to include paths for the CMake config file, in addition to only <prefix>"
- OFF)
+option(WITH_LEGACY_INCLUDE_PATH "Set to ON to add <prefix>/dlt to include paths for the CMake config file, in addition to only <prefix>" ON)
option(WITH_EXTENDED_FILTERING "Set to OFF to build without extended filtering. Using json filter files is only supported for Linux based system with json-c and QNX." OFF)
option(WITH_DLT_DAEMON_VSOCK_IPC "Set to ON to enable VSOCK support in daemon" OFF)