summaryrefslogtreecommitdiff
path: root/ACE/ACEXML/examples/SAXPrint/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ACE/ACEXML/examples/SAXPrint/Makefile.am')
-rw-r--r--ACE/ACEXML/examples/SAXPrint/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/ACE/ACEXML/examples/SAXPrint/Makefile.am b/ACE/ACEXML/examples/SAXPrint/Makefile.am
new file mode 100644
index 00000000000..075d3b6fca8
--- /dev/null
+++ b/ACE/ACEXML/examples/SAXPrint/Makefile.am
@@ -0,0 +1,48 @@
+## Process this file with automake to create Makefile.in
+##
+## $Id$
+##
+## This file was generated by MPC. Any changes made directly to
+## this file will be lost the next time it is generated.
+##
+## MPC Command:
+## /acebuilds/ACE_wrappers-repository/bin/mwc.pl -include /acebuilds/MPC/config -include /acebuilds/MPC/templates -feature_file /acebuilds/ACE_wrappers-repository/local.features -noreldefs -type automake -exclude build,Kokyu
+
+ACE_BUILDDIR = $(top_builddir)
+ACE_ROOT = $(top_srcdir)
+
+
+## Makefile.SAXPrint.am
+
+if BUILD_ACEXML
+if !BUILD_ACE_FOR_TAO
+noinst_PROGRAMS = SAXPrint
+
+SAXPrint_CPPFLAGS = \
+ -I$(ACE_ROOT) \
+ -I$(ACE_BUILDDIR) \
+ -I$(ACE_ROOT)/ACEXML/common
+
+SAXPrint_SOURCES = \
+ Print_Handler.cpp \
+ SAXPrint_Handler.cpp \
+ main.cpp \
+ Print_Handler.h \
+ SAXPrint_Handler.h \
+ SAXPrint_Handler.i
+
+SAXPrint_LDADD = \
+ $(ACE_BUILDDIR)/ACEXML/parser/parser/libACEXML_Parser.la \
+ $(ACE_BUILDDIR)/ACEXML/common/libACEXML.la \
+ $(ACE_BUILDDIR)/ace/libACE.la
+
+endif !BUILD_ACE_FOR_TAO
+endif BUILD_ACEXML
+
+## Clean up template repositories, etc.
+clean-local:
+ -rm -f *~ *.bak *.rpo *.sym lib*.*_pure_* core core.*
+ -rm -f gcctemp.c gcctemp so_locations *.ics
+ -rm -rf cxx_repository ptrepository ti_files
+ -rm -rf templateregistry ir.out
+ -rm -rf ptrepository SunWS_cache Templates.DB