summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorOssama Othman <ossama-othman@users.noreply.github.com>2004-05-14 17:07:36 +0000
committerOssama Othman <ossama-othman@users.noreply.github.com>2004-05-14 17:07:36 +0000
commite512d1889c9ebe450f75e57beff1eb947febbe1a (patch)
tree62e773facdc87faec3f532a92e1f4bf43d199ffb /configure.ac
parenteeeff7034d9ad81ff007f481a020703590793b09 (diff)
downloadATCD-e512d1889c9ebe450f75e57beff1eb947febbe1a.tar.gz
ChangeLogTag:Fri May 14 10:00:22 2004 Ossama Othman <ossama@dre.vanderbilt.edu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac125
1 files changed, 0 insertions, 125 deletions
diff --git a/configure.ac b/configure.ac
index bd87620511b..6f29d38bd4f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2118,131 +2118,6 @@ if test "$ace_cv_lib_auto_ptr_class" = yes; then
],,[AC_DEFINE([ACE_AUTO_PTR_LACKS_RESET])])
fi dnl test $ace_cv_lib_auto_ptr_class=yes
-dnl Check for ANSI C++ cast support
-ACE_CACHE_CHECK([for ANSI C++ cast support],
- [ace_cv_lib_posix_standard_casts],[
- ACE_CONVERT_WARNINGS_TO_ERRORS([
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[/* No headers */]],[[
- class B { public: int b_; virtual int b() const = 0; };
- class D : public B { virtual int b() const { return b_; } };
-
- void* vp = 0;
- char* cp = 0;
- float f = 1.0;
- int i = 0;
- int* ip = 0;
- const int* jp = 0;
-
- i = static_cast<int> (f);
- ip = const_cast<int*> (jp);
- cp = reinterpret_cast<char*> (vp);
-
- B* bp = new D;
- D* dp = dynamic_cast<D*> (bp);
- delete bp;
- ]])],[
- ace_cv_lib_posix_standard_casts=yes
- AC_CACHE_VAL([ace_cv_lib_rtti],[ace_cv_lib_rtti=yes])
- ],[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[/* No headers */]],
- [[
- class B { public: int b_; virtual int b() const = 0; };
- class D : public B { virtual int b() const { return b_; } };
-
- void* vp = 0;
- char* cp = 0;
- float f = 1.0;
- int i = 0;
- int* ip = 0;
- const int* jp = 0;
-
- i = static_cast<int> (f);
- ip = const_cast<int*> (jp);
- cp = reinterpret_cast<char*> (vp);
- ]])],
- [
- ace_cv_lib_posix_standard_casts=yes
- AC_CACHE_VAL([ace_cv_lib_rtti],[ace_cv_lib_rtti=no])
- ],
- [
- ace_cv_lib_posix_standard_casts=no
- ])
- ])
- ])
- ],
- [
- if test "$ace_cv_lib_rtti" != yes; then
- AC_DEFINE([ACE_LACKS_RTTI])
- fi
- ],
- [
- AC_MSG_ERROR([ACE requires a C++ compiler that supports ANSI C++ casts.])
- ])
-
-dnl Check for explicit C++ constructor support
-ACE_CACHE_CHECK([for explicit C++ constructor support],
- [ace_cv_feature_explicit_constructor],
- [
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-class Foo
-{
- public:
- explicit Foo (int i) { this->val_ = i; }
- private:
- int val_;
-};
- ]],[[
-Foo bar = 'a'; // error: no implicit char->Foo conversion
- ]])],[
-dnl The above test *should* fail!
- ace_cv_feature_explicit_constructor=no
- ],[
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
- [[
-class Foo
-{
- public:
- explicit Foo (int i) { this->val_ = i; }
- private:
- int val_;
-};
- ]],
- [[
-Foo bar (5);
- ]])],
- [
- ace_cv_feature_explicit_constructor=yes
- ],
- [
- ace_cv_feature_explicit_constructor=no
- ])
- ])
- ],[AC_DEFINE([ACE_HAS_EXPLICIT_KEYWORD])],)
-
-dnl Check for C++ mutable keyword
-ACE_CACHE_CHECK([for C++ mutable keyword],
- [ace_cv_feature_cxx_mutable_keyword],
- [
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
-class Foo
-{
- public:
- Foo (void) : val_ (0) {}
-
- mutable int val_;
-};
- ]],[[
-const Foo bar;
-
-bar.val_ = 3; // mutable declaration should allow this to be modified
- ]])],[
- ace_cv_feature_cxx_mutable_keyword=yes
- ],[
- ace_cv_feature_cxx_mutable_keyword=no
- ])
- ],[AC_DEFINE([ACE_HAS_MUTABLE_KEYWORD])],)
-
dnl Check if platform supports typename keyword
ACE_CACHE_CHECK([for C++ typename keyword],
[ace_cv_feature_posix_typename_keyword],[