summaryrefslogtreecommitdiff
path: root/system-version-manager/Makefile.am
diff options
context:
space:
mode:
authorPedro Alvarez <pedro.alvarez@codethink.co.uk>2014-02-20 18:41:28 +0000
committerPedro Alvarez <pedro.alvarez@codethink.co.uk>2014-03-06 16:50:21 +0000
commit3ff52dc3935ae52b5b633a98eec1eb1ff3be0f29 (patch)
tree042461f6a6fcf65732c813c702d2e35ead86b917 /system-version-manager/Makefile.am
parent5afdc1e8e66c565bbe2d5c8bb4669351043a3841 (diff)
downloadtbdiff-3ff52dc3935ae52b5b633a98eec1eb1ff3be0f29.tar.gz
Add script to modify the bootloader and manage different parallel OS.
This is part of the upgrades work. With this tool you can now switch between versions of the OS, remove a version, list all the versions present in the system, get the default version and the running version, and deploy a new system. All of the above is possible with the following subcommands: - list - deploy - get-default - get-running - remove - set-default It also activates a bootloader menu to choose a version to boot. The menu is important to make sure the user can boot the old OS if the new kernel doesn't work.
Diffstat (limited to 'system-version-manager/Makefile.am')
-rw-r--r--system-version-manager/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/system-version-manager/Makefile.am b/system-version-manager/Makefile.am
new file mode 100644
index 0000000..ddd0588
--- /dev/null
+++ b/system-version-manager/Makefile.am
@@ -0,0 +1,20 @@
+# vi:set ts=8 sw=8 noet ai nocindent:
+# -
+# Copyright (c) 2014 Codethink Ltd.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License Version 2 as
+# published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+# vi:set ts=8 sw=8 noet ai nocindent:
+
+bin_SCRIPTS = \
+ system-version-manager