summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-03-23 11:10:42 +0000
committerJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-03-23 13:19:36 +0000
commit81771871c53d24a084b54d116085028329312cf7 (patch)
treef4a66c127d8e50fcb20ad066bca2ba0332b6ebba /Makefile.am
parent837f58bdadda09a13b062929d6b5d448bdb5cabe (diff)
downloadtbdiff-81771871c53d24a084b54d116085028329312cf7.tar.gz
Add new tbdiff-update command to apply a patch to a system.
This command is written in bash and takes four parameters: * a device with a btrfs file system to mount * the source subvolume name * the target subvolume name * the path to a patch file or stream It then creates the target subvolume as a snapshot of the source subvolume, applies the patch in there, then creates a <target>-run snapshot and copies the boot files (vmlinuz, extlinux.conf) to the root file system. Lastly, it adjusts extlinux.conf to point to the -run snapshot.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2560896..e26010b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@ SUBDIRS = \
tbdiff \
tbdiff-create \
tbdiff-deploy \
+ tbdiff-update \
tests
.PHONY: ChangeLog