summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRichard Maw <richard.maw@codethink.co.uk>2012-07-31 09:43:09 +0100
committerRichard Maw <richard.maw@codethink.co.uk>2012-07-31 09:43:09 +0100
commitc04d82fdcc08743f799a7d25204df5be2a5f1f16 (patch)
tree4b0981d37470279c0698c035ddf634cb594eec04 /setup.py
parent93a3d28ee51cc301cd79ff8bfabb2010defda09b (diff)
downloadmorph-c04d82fdcc08743f799a7d25204df5be2a5f1f16.tar.gz
buildsystem: set package_data to install plugins
Plugins weren't installed because package installation doesn't by default include subdirectories. This would break system building on any morph which uses the plugins instead of having system build built-in. package_data seems to be the correct way to do this, as plugins aren't library files since they have different loading characteristics, such as different search paths and every found plugin is loaded, rather than on-demand.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9ff424d8..ee7c85e5 100644
--- a/setup.py
+++ b/setup.py
@@ -106,6 +106,7 @@ FIXME
url='http://www.baserock.org/',
scripts=['morph'],
packages=['morphlib'],
+ package_data={'morphlib': ['plugins/*_plugin.py']},
data_files=[('share/man/man1', glob.glob('*.[1-8]'))],
cmdclass={
'build': GenerateManpage,