summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-04-17 15:29:51 +0100
committerJannis Pohlmann <jannis.pohlmann@codethink.co.uk>2012-04-17 15:29:51 +0100
commit9ba282863b41bea8d9fe990a9aba92677e2f4501 (patch)
treec2067aed613ee82879179483f421c37f64188715 /setup.py
downloadmorph-9ba282863b41bea8d9fe990a9aba92677e2f4501.tar.gz
Initial import implementing /files and /sha1s.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..e861f392
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,46 @@
+#!/usr/bin/python
+#
+# Copyright (C) 2012 Codethink Limited
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; version 2 of the License.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+
+from distutils.core import setup
+
+
+setup(name='morph-cache-server',
+ description='FIXME',
+ long_description='''\
+FIXME
+''',
+ classifiers=[
+ 'Development Status :: 2 - Pre-Alpha',
+ 'Environment :: Console',
+ 'Environment :: Web Environment',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: System Administrators',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Build Tools',
+ 'Topic :: Software Development :: Embedded Systems',
+ 'Topic :: System :: Archiving :: Packaging',
+ 'Topic :: System :: Software Distribution',
+ ],
+ author='Jannis Pohlmann',
+ author_email='jannis.pohlmann@codethink.co.uk',
+ url='http://www.baserock.org/',
+ scripts=['morph-cache-server'],
+ packages=['morphcacheserver'],
+ )