summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <lars.wirzenius@codethink.co.uk>2013-02-28 11:48:13 +0000
committerLars Wirzenius <lars.wirzenius@codethink.co.uk>2013-02-28 11:48:13 +0000
commit63655166ea52d24101c59d91f8b222a42c105937 (patch)
tree6867b2a06069a37e041fd1d35730dad4074967a0 /setup.py
parent872f039f76238378add89baa4a3e7fe0f2a51a61 (diff)
downloadmorph-63655166ea52d24101c59d91f8b222a42c105937.tar.gz
Install plugins as a Python package, not package data
Previously, we were installing morphlib/plugins/*.py as package data. It now needs to be a proper Python package, so that "import morophlib.plugins" works (or "import morphlib.plugins.foo_plugin"). This requires us to install the morphlib/plugins/__init__.py file in setup.py, which this patch makes happen. Reported-By: Jonathan Maw
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index aaa164ac..b00b64a8 100644
--- a/setup.py
+++ b/setup.py
@@ -139,10 +139,9 @@ FIXME
author_email='lars.wirzenius@codethink.co.uk',
url='http://www.baserock.org/',
scripts=['morph'],
- packages=['morphlib'],
+ packages=['morphlib', 'morphlib.plugins'],
package_data={
'morphlib': [
- 'plugins/*_plugin.py',
'exts/*',
'version',
'commit',