summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRichard Maw <richard.maw@gmail.com>2014-10-01 16:36:43 +0000
committerRichard Maw <richard.maw@gmail.com>2014-10-01 16:36:43 +0000
commit4a371a2a69b657744f269d54c0af8732f69c7b0f (patch)
treef6d4d75dc3e526ba82f73536f2bc7197f686ee96 /setup.py
parent01060c72158893863162acec85f576c442fc49ff (diff)
parentacefe33868585cf31cda53474a3004da42e00896 (diff)
downloadmorph-4a371a2a69b657744f269d54c0af8732f69c7b0f.tar.gz
Merge in morph cache server
This is a runtime dependency of distbuild, so you can't exactly test distbuild without it. The cache server itself depends on bottle and flup, so rather than having a distbuild stratum and a trove stratum both containing the cache server, we should split morph out of the tools stratum and include it in both devel and trove systems.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 3 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 8125788f..60926779 100644
--- a/setup.py
+++ b/setup.py
@@ -133,10 +133,6 @@ class Check(Command):
setup(name='morph',
- description='FIXME',
- long_description='''\
-FIXME
-''',
classifiers=[
'Development Status :: 2 - Pre-Alpha',
'Environment :: Console',
@@ -152,8 +148,9 @@ FIXME
author='Codethink Limited',
author_email='baserock-dev@baserock.org',
url='http://www.baserock.org/',
- scripts=['morph', 'distbuild-helper'],
- packages=['morphlib', 'morphlib.plugins', 'distbuild'],
+ scripts=['morph', 'distbuild-helper', 'morph-cache-server'],
+ packages=['morphlib', 'morphlib.plugins', 'distbuild',
+ 'morphcacheserver'],
package_data={
'morphlib': [
'xfer-hole',