summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRichard Maw <richard.maw@codethink.co.uk>2012-07-31 12:52:12 +0000
committerRichard Maw <richard.maw@codethink.co.uk>2012-08-01 13:12:03 +0000
commit0032ccbd60f202ec76d9b738cddc8bdbf9f54133 (patch)
treecd398ab063be0bdab20b91cbd2420ad4981de813 /setup.py
parent93a3d28ee51cc301cd79ff8bfabb2010defda09b (diff)
downloadmorph-0032ccbd60f202ec76d9b738cddc8bdbf9f54133.tar.gz
python scripts: pep8ize codebase
This was done with the aid of the pep8 script, available by running `easy_install pep8`. It may be worth making this part of ./check, but that will require putting pep8 into the development tools stratum. This should be easy, given pep8 has no external dependencies.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 18 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 9ff424d8..1323ce98 100644
--- a/setup.py
+++ b/setup.py
@@ -1,15 +1,15 @@
#!/usr/bin/python
# Copyright (C) 2011, 2012 Codethink Limited
-#
+#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; version 2 of the License.
-#
+#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License along
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -55,7 +55,7 @@ class Clean(clean):
def run(self):
clean.run(self)
- itemses = ([self.clean_files] +
+ itemses = ([self.clean_files] +
[glob.glob(x) for x in self.clean_globs])
for items in itemses:
for filename in items:
@@ -83,23 +83,22 @@ class Check(Command):
os.remove('.coverage')
-
setup(name='morph',
description='FIXME',
long_description='''\
FIXME
''',
classifiers=[
- 'Development Status :: 2 - Pre-Alpha',
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU General Public License (GPL)',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python',
- 'Topic :: Software Development :: Build Tools',
- 'Topic :: Software Development :: Embedded Systems',
- 'Topic :: System :: Archiving :: Packaging',
- 'Topic :: System :: Software Distribution',
+ 'Development Status :: 2 - Pre-Alpha',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python',
+ 'Topic :: Software Development :: Build Tools',
+ 'Topic :: Software Development :: Embedded Systems',
+ 'Topic :: System :: Archiving :: Packaging',
+ 'Topic :: System :: Software Distribution',
],
author='Lars Wirzenius',
author_email='lars.wirzenius@codethink.co.uk',
@@ -108,9 +107,7 @@ FIXME
packages=['morphlib'],
data_files=[('share/man/man1', glob.glob('*.[1-8]'))],
cmdclass={
- 'build': GenerateManpage,
- 'check': Check,
- 'clean': Clean,
- },
- )
-
+ 'build': GenerateManpage,
+ 'check': Check,
+ 'clean': Clean,
+ })