summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorLars Wirzenius <lars.wirzenius@codethink.co.uk>2014-01-20 14:24:27 +0000
committerLars Wirzenius <lars.wirzenius@codethink.co.uk>2014-04-15 13:29:27 +0000
commit4fc162b07b2e9d8489e16ed647e5d96f5c66e10a (patch)
treeac2a2a5b86a5d789bd28b383851b28d7f293b928 /setup.py
parent716ad28c18ac00c52797dc42c843569b1834fb88 (diff)
downloadlorry-controller-4fc162b07b2e9d8489e16ed647e5d96f5c66e10a.tar.gz
Add new Lorry Controller
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 21 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..e214c33
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,21 @@
+#!/usr/bin/python
+#
+# Copyright (C) 2012-2014 Codethink Limited
+
+
+from distutils.core import setup
+import glob
+
+
+setup(name='lorry-controller',
+ description='Run Lorry on remote repositories in a controller manner',
+ author='Codethink Ltd',
+ author_email='baserock-dev@baserock.org',
+ url='http://www.baserock.com/',
+ scripts=['lorry-controller-webapp', 'lorry-controller-minion'],
+ packages=['lorrycontroller'],
+ data_files=[
+ ('share/lorry-controller/templates', glob.glob('templates/*')),
+ ('share/lorry-controller/static', glob.glob('static/*')),
+ ],
+ )