summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJavier Jardón <jjardon@gnome.org>2015-06-02 14:36:14 +0100
committerRichard Dale <richard.dale@codethink.co.uk>2015-06-26 11:20:40 +0100
commitebe40444e72d30d4d18ffafe53665369a9b0d0e0 (patch)
treefad9375c211fe8ed905e7a9af5819ba2acd9df10
parent0c19d54694b2f50adc6736d46f1a06f0626541bd (diff)
downloaddefinitions-baserock/rdale/openwrt-musl.tar.gz
stage2-binutils: No need to disable c++ anymorebaserock/rdale/openwrt-musl
We are generating a c++ compiler in stage 1, so no need to use the workaround introduced in commit e72775acb5326e948d2542622afb9bed4fd67c15 to be able to compile binutils without a c++ compiler This allows using upstream release tarballs of binutils, where before we had to patch out the AC_PROG_CXX statement from configure.in. Change-Id: I1ce9d2946f3a23a4355e8ec527a5ebfbce987d99 Conflicts: strata/build-essential/stage2-binutils.morph
-rw-r--r--strata/build-essential/stage2-binutils.morph2
1 files changed, 1 insertions, 1 deletions
diff --git a/strata/build-essential/stage2-binutils.morph b/strata/build-essential/stage2-binutils.morph
index 8da663e4..70a2ef66 100644
--- a/strata/build-essential/stage2-binutils.morph
+++ b/strata/build-essential/stage2-binutils.morph
@@ -8,8 +8,8 @@ configure-commands:
mips64*) ARCH_FLAGS="--with-arch=octeon2" ;;
esac
export STAGE2_SYSROOT="$(dirname $(pwd))"
- export CXX=false
TARGET_STAGE1=`echo $TARGET_STAGE1 | sed -e 's/bootstrap-linux-gnu/linux-musl/'`
+ export CXX="$TARGET_STAGE1-g++ --sysroot=$STAGE2_SYSROOT"
# binutils has its own embedded libtool, which is old and strips out
# `--sysroot`. Work around by modifying the compiler command to
# include the sysroot flag