summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRajat Vig <rajat.vig@gmail.com>2016-01-06 11:07:32 -0800
committerRajat Vig <rajat.vig@gmail.com>2016-01-06 11:41:34 -0800
commitce89118215cb9df2101a9e5fe16886ebfcf6cfe6 (patch)
tree520bacf1a4384a10f6ea7ef82e08d8a62efc569a /setup.py
parent78c1c82c43bc891d26036300747c40f05dd4c065 (diff)
downloadxstatic-jasmine-ce89118215cb9df2101a9e5fe16886ebfcf6cfe6.tar.gz
Update Jasmine to 2.4.1 from 2.2.0
Tested the upgrade locally and all tests passed. Deleted setup.cfg in favor of using information from the package in setup.py. Closes-Bug: #1531590 Change-Id: I79c85f45644d6267464fd002cd980c424e249642
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py48
1 files changed, 23 insertions, 25 deletions
diff --git a/setup.py b/setup.py
index 18d2f42..1fc4082 100644
--- a/setup.py
+++ b/setup.py
@@ -1,28 +1,26 @@
-# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
-#
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
-# implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
+from xstatic.pkg import jasmine as xs
-import setuptools
+# The README.txt file should be written in reST so that PyPI can use
+# it to generate your project's PyPI page.
+long_description = open('README.txt').read()
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
+from setuptools import setup, find_packages
-setuptools.setup(
- setup_requires=['pbr>=1.3'],
- pbr=True)
+setup(
+ name=xs.PACKAGE_NAME,
+ version=xs.PACKAGE_VERSION,
+ description=xs.DESCRIPTION,
+ long_description=long_description,
+ classifiers=xs.CLASSIFIERS,
+ keywords=xs.KEYWORDS,
+ maintainer=xs.MAINTAINER,
+ maintainer_email=xs.MAINTAINER_EMAIL,
+ license=xs.LICENSE,
+ url=xs.HOMEPAGE,
+ platforms=xs.PLATFORMS,
+ packages=find_packages(),
+ namespace_packages=['xstatic', 'xstatic.pkg', ],
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[],
+)