summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-07-29 21:22:58 +0000
committerKevin E Martin <kem@kem.org>2005-07-29 21:22:58 +0000
commitddabc8840aee8a90ea6b7f6fe8f1af7f692a2576 (patch)
tree6987084ebf5a19b8359897c1dbe7e0b8b772516c /Makefile.am
parentc8e6f83244036256d3f56c35ec8c60f03dc51275 (diff)
downloadxorg-util-makedepend-ddabc8840aee8a90ea6b7f6fe8f1af7f692a2576.tar.gz
Various changes preparing packages for RC0:
- Verify and update package version numbers as needed - Implement versioning scheme - Change bug address to point to bugzilla bug entry form - Disable loadable i18n in libX11 by default (use --enable-loadable-i18n to reenable it) - Fix makedepend to use pkgconfig and pass distcheck - Update build script to build macros first - Update modular Xorg version
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 49675d9..355b2f9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,8 +3,18 @@
bin_PROGRAMS = makedepend
man1_MANS = makedepend.man
-INCLUDES = -I${includedir} -I${includedir}/X11
-makedepend_SOURCES = include.c main.c parse.c pr.c cppsetup.c ifparser.c
+INCLUDES = @X_CFLAGS@
+
+makedepend_SOURCES = include.c \
+ main.c \
+ parse.c \
+ pr.c \
+ cppsetup.c \
+ ifparser.c \
+ ifparser.h \
+ def.h \
+ imakemdep.h
+
makedepend_CPPFLAGS = -DOBJSUFFIX=\".${OBJEXT}\" -DINCLUDEDIR=\"/usr/include\"
-EXTRA_DIST = autogen.sh
+EXTRA_DIST = autogen.sh makedepend.man