summaryrefslogtreecommitdiff
path: root/specs/Makefile.am
diff options
context:
space:
mode:
authorMatt Dew <matt@osource.org>2010-11-29 16:29:44 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-11-29 16:29:44 -0500
commit3102665110846af5c87792b221e1ef6a9dc1a0e2 (patch)
tree32d3456f8cc5b82c3f427f65232486e1d94bea5d /specs/Makefile.am
parentf6ee80371c4bf9ebd99418a4328a351186ac0847 (diff)
downloadxorg-proto-xextproto-3102665110846af5c87792b221e1ef6a9dc1a0e2.tar.gz
specs: add appgroup specs in DocBook/XML format
Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'specs/Makefile.am')
-rw-r--r--specs/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/specs/Makefile.am b/specs/Makefile.am
index 6fcafe7..a5d34fd 100644
--- a/specs/Makefile.am
+++ b/specs/Makefile.am
@@ -23,6 +23,7 @@
if ENABLE_SPECS
doc_sources = \
+ appgroup.xml \
dbe.xml \
dpms.xml \
evi.xml \
@@ -35,7 +36,7 @@ doc_sources = \
tog-cup.xml \
xtest.xml
-dist_doc_DATA = $(doc_sources)
+dist_doc_DATA = $(doc_sources) appendix.xml
if HAVE_XMLTO
doc_DATA = $(doc_sources:.xml=.html)
@@ -57,16 +58,16 @@ CLEANFILES = $(doc_DATA)
SUFFIXES = .xml .ps .pdf .txt .html
-.xml.txt:
+%.txt: %.xml $(dist_doc_DATA)
$(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) txt $<
-.xml.html:
+%.html: %.xml $(dist_doc_DATA)
$(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) xhtml-nochunks $<
-.xml.pdf:
+%.pdf: %.xml $(dist_doc_DATA)
$(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) --with-fop pdf $<
-.xml.ps:
+%.ps: %.xml $(dist_doc_DATA)
$(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) --with-fop ps $<
endif HAVE_XMLTO