summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-09 19:18:36 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-09 19:18:36 -0200
commit0b9de9e69e95872dd3eddbe5c1602e42c27c53e1 (patch)
treec41384199b6e9abc923498c212283c2507402187 /configure.ac
parent420efdba52593bf13d97c7e001b64caccd04cd5d (diff)
downloadxorg-lib-libXaw-0b9de9e69e95872dd3eddbe5c1602e42c27c53e1.tar.gz
Compile warning fixes.
This uses XORG_CHANGELOG macro to properly work with the "git-log" to "git log" change (required to pass "make distcheck"), uses the XORG_CWARNFLAGS macro. Most gcc 4.3 and sparse warnings corrected.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9ba2414..3927025 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,10 @@ AM_INIT_AUTOMAKE([dist-bzip2])
AM_CONFIG_HEADER(config.h)
+# Require xorg-macros: XORG_WITH_LINT, XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2.1 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2.1)
+
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
@@ -19,6 +23,8 @@ AC_PROG_LIBTOOL
# is in an if statement, and later calls would break if it's skipped.
PKG_PROG_PKG_CONFIG
+XORG_CWARNFLAGS
+
#
# fix libtool to set SONAME to libXaw.so.$major
#
@@ -60,7 +66,7 @@ AC_ARG_ENABLE(xaw6, AC_HELP_STRING([--disable-xaw6],
if test "x$build_v6" = xyes; then
PKG_CHECK_MODULES(XAW6, xproto x11 xext xextproto xt xmu)
-
+ XAW6_CFLAGS="$CWARNFLAGS $XAW6_CFLAGS"
AC_SUBST(XAW6_CFLAGS)
AC_SUBST(XAW6_LIBS)
fi
@@ -74,7 +80,7 @@ AC_ARG_ENABLE(xaw7, AC_HELP_STRING([--disable-xaw7],
if test "x$build_v7" = xyes; then
PKG_CHECK_MODULES(XAW7, xproto x11 xext xextproto xt xmu xpm)
-
+ XAW7_CFLAGS="$CWARNFLAGS $XAW7_CFLAGS"
AC_SUBST(XAW7_CFLAGS)
AC_SUBST(XAW7_LIBS)
fi
@@ -100,6 +106,7 @@ AC_CHECK_FUNCS([iswalnum])
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile
include/Makefile