summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu.herrb@laas.fr>2006-07-29 20:23:07 +0200
committerMatthieu Herrb <matthieu@reactor.herrb.com>2006-07-29 20:23:07 +0200
commited20661748b0070771116861972f5d1f00b45ed1 (patch)
tree49237ff1a715bea83c423031691f79e61f4a3c01 /Makefile.am
parent5faf9733ca4b632ec9a3640b00186b48052b3c03 (diff)
downloadxorg-lib-libXRes-ed20661748b0070771116861972f5d1f00b45ed1.tar.gz
Remove ChangeLog, add a rule to generate it with git-log.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8175fc9..b6bfc59 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,3 +31,10 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xres.pc
EXTRA_DIST = xres.pc.in autogen.sh
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ GIT_DIR=${srcdir}/.git git-log --name-only > ChangeLog
+
+dist-hook: ChangeLog