summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-07 18:51:23 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-06-07 18:51:23 +0000
commita30727351e6cdeb7ff2ffa0bddad8c3a1be9eda0 (patch)
tree067a48879e6ab74713fbd6c79d8640a4fe693666 /Makefile.am
parente47da1b068cd9b8a772a99e30b2c1d5271d4295e (diff)
downloadxorg-lib-libXRes-a30727351e6cdeb7ff2ffa0bddad8c3a1be9eda0.tar.gz
lib/XRes/include/X11/extensions - symlink.sh: Add XRes linking - xc/lib/XRes/*.c: conditionally include config.h - lib/XRes: add directories and build system.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..8175fc9
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,33 @@
+#
+# $Id$
+#
+# Copyright © 2003 Keith Packard, Noah Levitt
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+AUTOMAKE_OPTIONS = foreign
+
+SUBDIRS = src man
+
+AM_CFLAGS = $(RESOURCEEXT_CFLAGS) $(XRES_CFLAGS)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xres.pc
+
+EXTRA_DIST = xres.pc.in autogen.sh