summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2018-05-23 08:14:23 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2018-05-23 08:14:23 +1000
commit20bb8d6b9f4375557472dad67b5f8dcf31be27d3 (patch)
tree5e6c82074c74ea9b7d78d9cac463274fc457a951 /configure.ac
parent1e88664d958a000ac610ae9000459c461ba45bd8 (diff)
downloadxorg-driver-xf86-input-libinput-20bb8d6b9f4375557472dad67b5f8dcf31be27d3.tar.gz
Revert "Implement the custom acceleration curve options"
Custom pointer acceleration curves were reverted in libinput, so no point having this code here. This reverts commit d84e0035d12a9655c09a6e8c619b1144be42c90c. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 9c7174c..4e87591 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,16 +51,6 @@ OLD_LIBS=$LIBS
OLD_CFLAGS=$CFLAGS
LIBS="$LIBS $LIBINPUT_LIBS"
CFLAGS="$CFLAGS $LIBINPUT_CFLAGS"
-AC_MSG_CHECKING([if libinput_device_config_accel_set_curve_point is available])
-AC_LINK_IFELSE(
- [AC_LANG_PROGRAM([[#include <libinput.h>]],
- [[libinput_device_config_accel_set_curve_point(NULL, 0, 0)]])],
- [AC_MSG_RESULT([yes])
- AC_DEFINE(HAVE_LIBINPUT_CUSTOM_ACCEL_CURVE, [1],
- [libinput_device_config_accel_set_curve_point() is available])
- [libinput_have_custom_accel_curve=yes]],
- [AC_MSG_RESULT([no])
- [libinput_have_custom_accel_curve=no]])
AC_MSG_CHECKING([if libinput_device_touch_get_touch_count is available])
AC_LINK_IFELSE(
[AC_LANG_PROGRAM([[#include <libinput.h>]],